PHP SDK 2.1.0 With WAMP 2.5 and PHP 5.5

Here is my specs

WAMP 2.6
PHP 5.5
Couchbase SDK 2.1.0

downloaded x64 VC11 NTS.
copied php_couchbase.dll to the /wamp/bin/php/php_XXX/ext/ folder
copied libcouchbase.dll to the /wamp/bin/php/php_XXX/ folder
i even copied libcouchbase.dll to /windows/system32 and to apache’s bin folder

php.ini, added extension=php_couchbase.dll

wamp boots ok, but php logs says The specified module could not be found. in Unknown on line 0

And …

since trying to make it work messed up my wamp, i decided to install the latest
with php 5.6
apache 2.4.17

still doesnt work …

Here I assume that you are using WAMP 2.5, and not 2.6 as you wrote in the message. Which is accessible at 2/Wampserver 2.5/. PHP extension 2.1.0 located at Unpacked extension into C:\wamp\bin\php\php5.5.12\ext\php_couchbase.dll and libcouchbase.dll somewhere in the PATH (In my case into C:\wamp\bin\php\php5.5.12\libcouchbase.dll and C:\wamp\bin\apache\apache2.4.9\bin\libcouchbase.dll).

Couple things here:

  1. wamp does not ship php5.dll (NTS version), but rather php5ts.dll (ZTS version), so you used incorrect archive
  2. when extension is loading, it looks up for libcouchbase.dll in the PATH or in current directory of the process so this DLL should be accessible there (for some reason OS keep removing libcouchbase.dll from C:\windows\system32.
  3. when registering extension for CLI mode, use C:\wamp\bin\php\php5.5.12\php.ini, and for apache, use C:\wamp\bin\apache\apache2.4.9\bin\php.ini. The real INI file location you can always findout during runtime:


C:\wamp\bin\php\php5.5.12>php --ini
Configuration File (php.ini) Path: C:\Windows
Loaded Configuration File:         C:\wamp\bin\php\php5.5.12\php.ini
Scan for additional .ini files in: (none)
Additional .ini files parsed:      (none)

Apache httpd:

So if you did everything like I’ve described above, you should be able to successfully verify installation:


C:\wamp\bin\php\php5.5.12>php.exe -i | find "couchbase"


hi avsej

sorry i was not able to reply right away after i had it working in wamp 3

when wamp 2.5 was still installed, i tried both nts and zts DLLs and neither worked until all of a sudden my wamp messed up and i had to reinstall again, decided to install wamp 3 (not 2.6, my bad)

it is working now. thank you

So with clean install, ZTS and libcouchbase.dll in the directory with executable it works?

yes that is correct

clean install. as wamp requires to fully uninstall if one plans to upgrade to a higher version.

and zts (since the file in the php/ folder is php5ts.dll) + libcouchbase

now working.


Can you please reply how we can insatll php sdk on xampp .