Operator helm and CAO install fails with internal error - failed calling webhook for admission

New cluster, running Cilium as CNI (with no network restrictions), and Kubadm cluster.
Installing via proven (with operator 2.4.0) in the past, but helm install and CAO install both fail with same error:

* Internal error occurred: failed calling webhook "couchbase-operator-admission.couchbase.svc": failed to call webhook: Post "https://couchbase-operator-admission.couchbase.svc:443/couchbaseclusters/validate?timeout=10s": service "couchbase-operator-admission" not found

It seems strange that it’s calling for ‘couchbase-operator-admision’ but the service name is ‘couchbaseoperator-couchbase-admission-controller’…
If I look at DNS shows this:

I see other posts with this error talking about removing a webhook mutuation configuration, but not sure where that is, I’m deleting everything and the namespace before trying this…
Can anyone give me a hint?

can you share the steps for installing with helm?
I’ll see if I can reproduce the issue locally

sure, thanks, see below and attached: (this references 2.4.0 (which worked before) but have tried same procedure with 2.4.1 and 2.4.2 with same outcome

helm repo add couchbase Helm Guide for the Couchbase Operator
helm repo update
kubectl create ns couchbase
kubectl -n couchbase apply -f couchbase-autonomous-operator_2.4.0-194-kubernetes-linux-amd64/crd.yaml
helm install --debug -n couchbase --set tls.generate=true --values couchbase-values.yaml --set cluster.name=couchbasedev couchbaseoperator couchbase/couchbase-operator | tee out.txt

(same user, password and domain are changed obviously)
couchbase-values.zip (3.9 KB)

and note that it has the same error if you just use the default couchbase-cluster.yaml from the distributions directory…
I must be something to do with my environment, since this same stuff worked before, and the only difference is the use of cilium for CNI, ingress and api gateway…
@aemery-cb appreciate your help to let me know
OR maybe it’s my k8s version, I am using 1.27 (which the install tells me is not supported yet). Could this be the issue?

I think it’s resolved, there must have been something left over and not cleaned from cao install when I was trying that…went through and ensured all resources that I could identity were deleted, and now the thing is coming up ok.