Not able to connect to query port 8093 on 'queryEnabled(true)'

I am not able to connect to query port after making queryEnabled(true)

Code Snippet:

    CouchbaseEnvironment env = DefaultCouchbaseEnvironment.builder()

NOTE: I am using couchbase-server-community_3.0.1 edition and java-client v 2.1.4.


[WARN] [null][QueryEndpoint]: Could not connect to endpoint, retrying with delay 32 MILLISECONDS: Connection refused: no further information: localhost/
	at Method) ~[na:1.7.0_71]
	at ~[na:1.7.0_71]
	at ~[core-io-1.1.4.jar:1.1.4]
	at$AbstractNioUnsafe.finishConnect( ~[core-io-1.1.4.jar:1.1.4]
	at [core-io-1.1.4.jar:1.1.4]
	at [core-io-1.1.4.jar:1.1.4]
	at [core-io-1.1.4.jar:1.1.4]
	at [core-io-1.1.4.jar:1.1.4]
	at$ [core-io-1.1.4.jar:1.1.4]
	at$ [core-io-1.1.4.jar:1.1.4]
	at [na:1.7.0_71]
[DEBUG] Received signal for outdated configuration.

@vinod the queryEnabled setting was only needed for experimental N1QL support with the external cbq-query component. Now all you need to do is download the 4.0 RC0 release and the query engine will be found automatically. So you dont need to set that at all. Either use 3.0 features without N1QL or try it out by using 4.0 RC0

@daschl, I am working on 3.0.1 and can’t use 4.0 RC0 at this moment.
Could you please guide me run N1QL with my existing setup?

@vinod the whole cbq-engine thing was experimental and not meant to be used in production. Since the 4.0 builds shipped, we discontinued the individual query components. You can use the old ones, but I would not recommend that.