NO DOCUMENT FOUND, Documents shows no Results But Documents Exist and can visible by Classic editor

I am using Community Edition 6.5.1 build 6299 PREVIEW MODE.

I am really facing an unusual problem, When i go to Documents and try to retrieve documents it says No Results
Even i can not retrieve documents using Query Editor.

I have also tried with REST API via postman

But i can see the documents are exist via CLASSIC EDITOR

what kind of problem i am experiencing? is this happen to anyone before?
Now I am under doubt how couchbase server will perform on production?

As far as N1QL is concern check if you have entries in the index. Try the N1QL with USE KEYS on of the document key.

I have index entries still not working…

Index showing 0 entries. that is why query is giving 0 results.

How it becomes 0 ?
i had created index before and i did not change anything which might cause this error.

to resolve this i just deleted the previous primary index and trying to new one but it seems not working

something really bad happen. its really giving be doubt should i use it on production or not?

i have found the following error on Logs

any suggestion what to do next?

@vsr1 any suggession? how can i restart index service?

@mostain You can kill the “indexer” process on the node using the platform-appropriate tool (e.g., on linux use ‘kill -9’), and Couchbase Server should restart the indexer within a few seconds.

@eben thank you eben for your response.

I have tried but no luck. couchbase server has issues, you must fix it.
Still it is not much robust as Mysql or other Sql engine.