Installation issues (packages) - Hash Sum mismatch

Hi there!
I came to you with installation problems. Issue appeared today - I used the same process for the last few months and it always worked. (

Get:5 xenial/xenial/main amd64 Packages [1449 B]
Err:5 xenial/xenial/main amd64 Packages
Hash Sum mismatch

And then…

e[91mE: Failed to fetch
Hash Sum mismatch
E: Some index files failed to download. They have been ignored, or old ones used instead.

Did you deployed something in the last 24hrs?
Is there any hotfix to make it work?

I did release a new version yesterday, but it’s strange that there’s a checksum mismatch. I’ve just verified that it does indeed work on Xenial, so I’m guessing it’s something specific to your environment.

It started working about 3hrs ago. I did not change anything, it was something on your side I guess.
Anyway thanks for double-check!



I have the same problem.
Tried the installation manual, wget, dpkg -i 1.0.3 (also tried 1.0.2) and as soon as I want to update with apt-get I get a hash checksum mismatch. (Machine is a freshly installed 16.04 ubuntu)

Get:6 xenial/xenial/main amd64 Packages [1,451 B]
Err:6 xenial/xenial/main amd64 Packages
  Hash Sum mismatch

I tried to fix it with various solutions (removing apt lists, apt-clean, …) but none of them worked.
is there something wrong with that mirror ?


Interesting. I did just upload a new version yesterday.

I just tried it again, and it works… do you have an HTTP proxy somewhere?

Just wanted to inform you, today it started to work again!
I did nothing just repeated the install steps and this time no checksum mismatch.

the machine was running since yesterday without a reboot or any other installations…

Seems to be a repository caching issue or something like this ?
Hope that helps!
regards alex

It might just be AWS acting strange. Some similar stuff happened last month with the release there as well.

Having this issue today:

E: Failed to fetch  Hash Sum mismatch
E: Some index files failed to download. They have been ignored, or old ones used instead.

Do not worry, this is CloudFront issue as it need some time to invalidate its cache. The problem will be automatically resolved in 24 hours, or earlier.

Meanwhile you can use tarballs with binary packages from archives page.

By no means am I a cloudfront expert but wouldn’t it be a good idea to invalidate the cache over asking me to use a different package?

This is totally great idea. Invalidation in progress. Stay tuned.

Thank you for feedback

1 Like

Seems to be happening again today.
91mW: Failed to fetch Hash Sum mismatch
This is very disruptive because we have builds that depend on this package.

Thank you, all is well again.

Hi, I’m currently experiencing this issue, and it is blocking our builds.

This seems to happen on any new Couchbase release, and is quite frustrating.

@drohde, do you see it now with libcouchbase? That’s strange and should be something new, because we haven’t made any releases recently

Thanks, the hash sum mismatch was resolved a few hours after I posted. Perhaps cache was stale?

No issues now