Indexing / Backfill issue when running Couchbase 6.0 in mixed environments

Hi, we have a somewhat unusual requirement of running couchbase cluster across both Windows Server 2016 and RHEL6. We’re seeing the following issue when cetain N1QL queries are run in our pre-production system:

“msg”:“open C:/Program Files/Couchbase/Server/var/lib/couchbase/tmp/scan-results7483778648104: no such file or directory - cause: open C:/Program Files/Couchbase/Server/var/lib/couchbase/tmp/scan-results7483778648104: no such file or directory”,“code”:5000}

We suspect this is related to differing file paths on windows/linux and when we remove the linux nodes from the cluster the issue seems to be resolved.

We’re currently reproducing the issue with Couchbase CE 6.0 and this seems to be related to this new feature:

Is there any way to work around this? Is it possible to disable backfill?

The above link has info how to disable backfill
0 will disable backfill

So it is! That’s very helpful thank you. Can we assume that it’s safe to disable backfill if we’re confident our indexes/query results are small enough to fit in allocated RAM? We should be well provisioned in terms of memory/cpu for the data we’re managing. Would you be able to point me to the docs for the settings we might need to tune to ensure we don’t need backfill for posterity?

Thanks again!

In cases where query service cannot consume results fast enough from indexer, backfill helps to reduce the load on indexer by writing results to disk files for query service. Indexer can then free up the snapshots which were being used to serve the query requests. If for your workload(mutation ingest rate, scan rate), the scan performance and indexer memory usage after disabling backfill is acceptable, you should be okay.

1 Like