Increment Operation throwing "Cannot Mutate " Errors

I am trying to use the increment operation passing a delta of 1 and default value of 1.

It works sometimes and other times it throws exception and the exception is as follows :

“Mutate operation failed, see InnerException or StatusCode for details.”

The Status Code is empty.

I am using .Net Client

Does any one know why this is happening.


Which version of the client are you using?

I am using .Net Client 1.2.6.

Forgot to mention I was using Memcached Bucket. Not sure if it makes a difference.

Does this happen every single time or only occasionally?

It does not happen every single time. But it does happen like frequently enough to cause problem.

I have you tried updating the client to the latest version? In earlier versions, some of the error messaging wasn’t bubbling up from the IO layer, which is probably why the status code and message are empty.

Also, which version of the server are you using?

i haven’t tried to update to latest version. Because when I saw the fixes, nothing that was related to this is present. I agree that status code might help. But I was wondering if you guys saw this before.

I also noticed, it says unable to locate node just for increment operation.

I am using 2.0.1 version.