HTTP error 401 Unauthorized getting pools

I am getting the following error when I try and start the cbq-engine against my 2.2 cb server. Is there anything I need to do to pass along a username and password?

ZEN0049p:n1ql john.blayter$ ./cbq-engine -couchbase
08:42:29.125970 FATAL: Unable to run server, err: Unable to access site, err: HTTP error 401 Unauthorized getting “”: – main.main() at main.go:62
ZEN0049p:n1ql john.blayter$

Have you tried:

./cbq-engine -couchbase http://username:password@

1 Like

Thank you! that worked

Note that in the Developer Preview 1, there is no support for authentication from client side. So, if you run the server with a specific set of credentials, all query clients will gain access to that bucket without requiring any authentication. This limitation is because it is a developer preview, and proper authentication will be in place in the near future.

To add to what Siri said there are actually 2 issues.

  1. There is currently no support for querying password protected buckets (see

  2. If all your buckets are password protected, access to /pools on the server requires admin credentials (see

If you add at least one non-password protected bucket you should be able to connect the query-engine, and you should be able to query this bucket.

Future releases should address these issues.

NOTE: this developer preview release is not intended to be used on production buckets