Getting RequestCanceledException Reason: NO_MORE_RETRIES exception sometimes

com.couchbase.client.core.error.RequestCanceledException: GetRequest, Reason: NO_MORE_RETRIES (COLLECTION_MAP_REFRESH_IN_PROGRESS) {"cancelled":true,"completed":true,"coreId":"0x6b310c6700000001","idempotent":true,"lastChannelId":"6B310C6700000001/0000000076E98659","lastDispatchedFrom":"","lastDispatchedTo":"","reason":"NO_MORE_RETRIES (COLLECTION_MAP_REFRESH_IN_PROGRESS)","requestId":106,"requestType":"GetRequest","retried":0,"service":{"bucket":"test","collection":"test","documentId":"123456","opaque":"0x332","scope":"test","type":"kv","vbucket":557},"timeoutMs":2500,"timings":{"totalMicros":5161}}
        at com.couchbase.client.core.msg.BaseRequest.cancel(
        at com.couchbase.client.core.retry.RetryOrchestrator.lambda$maybeRetry$0(
        at java.util.concurrent.CompletableFuture.uniWhenComplete(
        at java.util.concurrent.CompletableFuture.uniWhenCompleteStage(
        at java.util.concurrent.CompletableFuture.whenComplete(
        at com.couchbase.client.core.retry.RetryOrchestrator.maybeRetry(
        Suppressed: java.lang.Exception: #block terminated with an error
                at reactor.core.publisher.BlockingSingleSubscriber.blockingGet(
                at reactor.core.publisher.Mono.block(

Hi @rishabh_katyal . Please see comments from myself and David on similar issue java - COLLECTION_MAP_REFRESH_IN_PROGRESS reason with RequestCancelledException while connecting to couchbase - Stack Overflow

@graham.pople Do we need to use ?

I tried to use it in application however still getting the same exception.

21:32:01.097 [main] ERROR o.s.batch.core.step.AbstractStep - Encountered an error executing step TestUpdateStep in job TestJob
21:32:01.103 [cb-events] INFO com.couchbase.request - [com.couchbase.request][RequestNotRetriedEvent] Request GetRequest not retried per RetryStrategy (Reason: COLLECTION_MAP_REFRESH_IN_PROGRESS) {“cancelled”:true,“completed”:true,“coreId”:“0xf7729a0d00000001”,“idempotent”:true,“lastChannelId”:“F7729A0D00000001/000000001A1870D5”,“lastDispatchedFrom”:“”,“lastDispatchedTo”:“stg-xxxxxxxxxxxxxxxxxxx”,“reason”:“NO_MORE_RETRIES (COLLECTION_MAP_REFRESH_IN_PROGRESS)”,“requestId”:81,“requestType”:“GetRequest”,“retried”:0,“service”:{“bucket”:“bucket”,“collection”:“collection”,“documentId”:“202106”,“opaque”:“0x6d”,“scope”:“scope”,“type”:“kv”,“vbucket”:550},“timeoutMs”:2500,“timings”:{“totalMicros”:6440}}

I would try longer than that - 30 or 60 seconds should be fine - and also try applying the “wan-development” profile which will increase your timeouts for a WLAN development environment (Start Using the Java SDK | Couchbase Docs)

@graham.pople Even after changing to 60 seconds I am still facing the same alert.
I have not added the “wan-development” profile as of now. Do you think that will help?

@graham.pople By the way i have not used kvTimeout so by default it is taking 2.5seconds.

I understand that the waitUntilReady waits for the cluster to be ready before an operation is performed.
I already added that configuration in code.
But how about the fetching the records using “id” as the key?
In my application, the key value timeout is not set currently. So, there will be a default timeout of 2.5 seconds. In case of timeout, will there be same error as shared by me in the post?

Setting the wan-development profile increases the timeouts which yes, should help with this scenario.

@graham.pople The wan profile changes the configuration to below. So, is it ok to use these setting instead of directly using wan profile?

connectTimeout 20s
kvTimeout 20s
kvDurableTimeout 20s
viewTimeout 120s
queryTimeout 120s
analyticsTimeout 120s
searchTimeout 120s

It is, it will do the same thing

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.