Fatal Exception: java.lang.UnsatisfiedLinkError


I have been seeing these crashes in my logs on some of my applications, I am trying to understand what what this error actually means and what would be causing this kind of error/what can I do to reduce these errors.

Any advice is much appreciated.

Fatal Exception: java.lang.UnsatisfiedLinkError: No implementation found for void com.couchbase.lite.internal.core.C4Log.setCallbackLevel(int) (tried Java_com_couchbase_lite_internal_core_C4Log_setCallbackLevel and Java_com_couchbase_lite_internal_core_C4Log_setCallbackLevel__I)
       at com.couchbase.lite.internal.core.C4Log.setCallbackLevel(C4Log.java)
       at com.couchbase.lite.internal.core.C4Log.setCoreCallbackLevel(C4Log.java:114)
       at com.couchbase.lite.internal.core.C4Log.setCallbackLevel(C4Log.java:103)
       at com.couchbase.lite.AbstractConsoleLogger.setLevel(AbstractConsoleLogger.java:61)
       at com.couchbase.lite.ConsoleLogger.setLevel(ConsoleLogger.java:25)
Fatal Exception: java.lang.UnsatisfiedLinkError: No implementation found for long com.couchbase.lite.internal.core.C4Database.open(java.lang.String, java.lang.String, int, int, byte[]) (tried Java_com_couchbase_lite_internal_core_C4Database_open and Java_com_couchbase_lite_internal_core_C4Database_open__Ljava_lang_String_2Ljava_lang_String_2II_3B)
       at com.couchbase.lite.internal.core.C4Database.open(C4Database.java)
       at com.couchbase.lite.internal.core.C4Database.getDatabase(C4Database.java:156)
       at com.couchbase.lite.AbstractDatabase.openC4Db(AbstractDatabase.java:1069)
       at com.couchbase.lite.AbstractDatabase.<init>(AbstractDatabase.java:271)
       at com.couchbase.lite.AbstractDatabase.<init>(AbstractDatabase.java:246)
       at com.couchbase.lite.Database.<init>(Database.java:101)

My suggestion would be that you add the following information:

  • What version of CBL are you using?
  • Is this on a JVM or is it on Android
  • What version of JVM/Android are you using.

Maybe then we can figure out what’s up.

Hi @blake.meike

Apologies for leaving that information out.

I am using couchbase light version 3.0.0 on android.
In my logs this crash has ocured on devices running android 9 and android 11.

This is pretty strange!

There have been no changes to that code since v2.8. Both 2.8 and 3.0 are in common use and this is the first I’ve heard of this.

Is logging working at all? For that matter, is Couchbase Lite working at all (can you create, save, and update documents). Is it possible that the error we should be looking at is the failure to load the native library?

Yeh my thoughts as well!

Unfortunately I have not been able to replicate this locally so I don’t have logs.
I have just seen it in the firebase crashlytics logs, the crashes don’t seem too common, it seems to happen a few times a week.

I must assume that couchbase is working most of the time as otherwise these users would not be able to use our system and we have not had reports of issues from clients.

I wonder if it is something specific to these devices, they seem to only occur on Chainway C66 and OnePlus 8 Pros. What I can see from our analytics is we have about 200 of these devices in use so it seems they work most of the time.

I have opened ticket CBL-3882 to track this. I’m afraid that’s about all I’ve got, for now. I don’t have nearly enough information to guess at what is going on, yet, so anything additional that you can provide would be great.

Thank you, appreciate the assistance

this is useful information

I am using couchbase light version 3.0.0 on android.
In my logs this crash has ocured on devices running android 9 and android 11.

Just to advise, I have updated to 3.0.4 and the issue is still persisting in that version.

Thank you, appreciate the assistance