Dpkg: error processing archive couchbase-release-1.0-4-amd64.deb (--install):

i’m trying to install Couchbase server on a virtual machine (virtual box) running
Ubuntu Server 18.04 (GNU/Linux 4.15.0-23-generic x86_64).
Following this guide, if i run

sudo dpkg -i couchbase-release-1.0-4-amd64.deb

console shows me:

(Reading database ... 103765 files and directories currently installed.)
Preparing to unpack couchbase-release-1.0-4-amd64.deb ...
Supported platforms are: Debian/wheezy,jessie and Ubuntu/lucid,precise,trusty,xenial

dpkg: error processing archive couchbase-release-1.0-4-amd64.deb (--install):
 new couchbase-release package pre-installation script subprocess returned error exit status 1
Errors were encountered while processing:

What am i missing?
I’ve already tried the docker solution and it worked, and now i would like to install permanently because i’d like to test it in “production mode”.

NB: i checked out this topic, and it seemed having the same problem. I checked systemd, and it’s on pid 1, so it should’t be that.

Thank you in advance

The problem is that the couchbase-release package checks the distribution on install to ensure it matches the supported platforms, and Bionic (Ubuntu 18.04) isn’t a supported platform yet.

1 Like

No, distribution is not a problem there is also the same issue on Ubuntu Xenial and Trusty

Hmm. Can you check to see if the ‘lsb-release’ package is installed on your system? The couchbase-release package depends on the lsb_release command which is provided by that package.

1 Like

lsb-release is installed and Im getting the same error all the time, checked Mint 18 and Ubuntu 16.04 Xenial

Mint 18 is not a supported distro either. It should definitely work on Ubuntu 16.04 however. I’ve verified it working in an Ubuntu 16 Docker container so long as lsb-release is installed.

Can you tell me the output of “lsb_release -a” on your Ubuntu 16 system?

1 Like

Thanks for replay, I managed to install it. The solution was to change distrocode for Xenial Xenial in lsb_release. It works now both on Mint 19 and Ubuntu 18.04


Glad you’re unstuck!

The issue is still not resolved.
However this table shows that Ubuntu 18.04 is supported.
Does CB support ubuntu 18.04 or not?

There is a newer version of the couchbase-release.deb file: packages.couchbase.com/releases/couchbase-release/couchbase-release-1.0-6-amd64.deb

That should include support for Bionic.
It appears our installation documentation hasn’t been updated and still references the 1.0-4 couchbase-release package. I’ve filed a ticket to get that updated.

1 Like

Im running into this same issue/error with couchbase-release-1.0-6-amd64.deb . Im running 18.04 . Any ideas?

On Ubuntu 18.04, 1.0-6 should definitely work. I just tried it in a local Docker container. You do need to have the lsb-release package installed as mentioned earlier.

Can you cut/paste the command you’re running and the error it produces? And to verify, what is the output of “lsb_release -a” ?

This is what I get:

localadmin@prod-couchbase04:~ sudo curl -O https://packages.couchbase.com/releases/couchbase-release-1.0-6-amd64.deb % Total % Received % Xferd Average Speed Time Time Time Current Dload Upload Total Spent Left Speed 100 313 0 313 0 0 6260 0 --:--:-- --:--:-- --:--:-- 6260 localadmin@prod-couchbase04:~ sudo dpkg -i ./couchbase-release-1.0-6-amd64.deb
dpkg-deb: error: ‘./couchbase-release-1.0-6-amd64.deb’ is not a Debian format archive
dpkg: error processing archive ./couchbase-release-1.0-6-amd64.deb (–install):
dpkg-deb --control subprocess returned error exit status 2
Errors were encountered while processing:
localadmin@prod-couchbase04:~$ lsb_release -a
LSB Version: core-9.20170808ubuntu1-noarch:security-9.20170808ubuntu1-noarch
Distributor ID: Ubuntu
Description: Ubuntu 18.04.4 LTS
Release: 18.04
Codename: bionic

I got this figured out, thanks for your time.

It appears your first download was corrupted. Glad you got it worked out.