Different Class Not Found Issues Migrating to multi-cluster-java 2.0.0

List specs = new ArrayList<>();
ClusterEnvironment environment = ClusterEnvironment.create();

    Coordinator coordinator = Coordinators.isolated(environment, specs, new IsolatedCoordinator.Options()

    TrafficMonitoringFailureDetector.Options opts = TrafficMonitoringFailureDetector.options()
        // Add for service scope like ---> .serviceScope(Arrays.asList(ServiceType.BINARY, ServiceType.QUERY))
        // for node-local rather than global tracking ---> .nodeScope(true)
    FailureDetectorFactory<?> detector = FailureDetectors.trafficMonitoring(coordinator, opts);

     * Initialize the client and open the collection
    McaCluster cluster = new McaCluster(coordinator, detector);
    McaBucket mcaBucket = cluster.bucket("travel-sample");
    McaCollection mcaCollection = mcaBucket.defaultCollection();

POM Dependencies:



with core-io 2.2.6 and 2.2.5 versions(seeing nested exception is java.lang.NoClassDefFoundError:

So, tried going back to older version of couchbase-core-io dependency, it fixed this “ThresholdRequestTracer” issue but seeing new Exception for “CoreQueryAccessor” class that is available in versions after 2.2.0
nested exception is java.lang.NoClassDefFoundError:com/couchbase/client/core/msg/query/CoreQueryAccessor


@Raghavendra_P you should use the transitive dependencies that automatically pull in the right SDK so you are not running into such issues. If you depend on the MCA client, it will pull in the correct and tested version automatically.

2.0.0 depends on Java-Client 3.1.5 (which in turn automatically pulls in core-io 2.1.5). If you have issues with those versions please let us know and we’ll work through those.

thankyou @daschl, worked without issues with MCA 2.0.0 and java-client 3.1.8