Couchbase-net-client-2.0-dp3 -> SELECT don't work at all

I took the last couchbase-net-client-2.0-dp3
Inserting and updating of the documents works fine
The interesting part is that I can’t select anything using N1QL

I also tried version 1 and version 2 and I have the same problem.
In version 1 -> results.Rows is NULL
In version 3 -> Result.Rows has size = 0

I tried all kind of select statements:
“SELECT * FROM :system.buckets” ,
“SELECT ‘HI’ as HelloWorld”,
“SELECT ‘HI’ from default”,
Strange is that all these strings return results.Success = TRUE, even the last one :slight_smile:
But inserting and updating of the documents works.

I don’t have any VIEW on my Couchbase Server
I also don’t have any INDEX

Do you have any idea of what i can try to make the N1QL SELECT statement to work ?

Thank you,
Andrei Nechifor

Hi ANdrei -

The Couchbase .NET SDK’s developer preview’s N1QL support is limited to the N1QL tutorial database, which is looking at http://localhost:8093/. This will change shortly and should be integrated into Couchbase Server by GA in late September of this year.

To try it out, install the N1QL DP3 and then start the tutorial:

Step 1. Expand the package archive

Step 2. Run ./ (On Windows start_tutorial.bat)

Once you do this, you should be able to run N1Ql queries against the tutorial database using one of the .NET SDK DP’s.

Hope this helps,