Couchbase docker container hangs in warmup / initialize / yellow node status

Hi all,

I’ve tried a number of times, with different versions of the official couchbase docker container (, it happens randomly but it’s pretty often. When I kick start the couchbase docker container, it’d stuck in the warmup phase, with a yellow status icon, warmup progress says “initialize”.

It might take up to half an hour, or sometimes I couldn’t wait so tried stopping the container and restarting it, and it might take a few restarts with quite some delay before the container comes up properly.

Is it just me or do you guys have any such issues running the Couchbase container?


Hi @eugene.parks,

I’ve run the docker containers many times, and I haven’t run into that problem before. What OS are you using? Also, which release are you using at couchbase/server? You might also consider trying:

Hi there,

Yes I’ve been using the official couchbase docker images, e.g. community-4.5.1 & enterprise-4.6.1 on Linux hosts. (both ubuntu 14.04 LTS & 16.04 LTS)

Just earlier today on my dev workstation running Ubuntu 16.04 LTS I’ve run into this issue like 3 times already. I was wondering maybe running “docker stop” on the couchbase container might not shut down couchbase properly and that’s why the next time it starts up it’d take a long time to warm up again?

I’ve even tried firing up a google compute engine instance with debian 8 and i also encountered this. So i’m actually surprised to hear that you haven’t run into this issue…

That’s why I’ve actually turned away from the container and had to install the couchbase binary onto my production server directly.

So in your experience the couchbase docker images work just fine and could possibly be production ready?


Hi @eugene.parks,

As far as I know, the Couchbase Docker images are production ready and supported. I’m tagging @anil to see if he has any more insight.