Couchbase - Configuring an Ingress

I trying to setup my couchbase in GKE

First, I follow this Create a Couchbase Deployment | Couchbase Docs to setup and everything looks good

Then, I want to access my couchbase extenally. So, I go to study another document Access the Couchbase Server User Interface | Couchbase Docs.

So I hope, I can access my couchbase thru ingress. So i follow - “Configuring an Ingress” and below is the yaml file

kind: Ingress
name: my-ingress
annotations: cookie persistent

  • http:
    • path: /
      pathType: Prefix
      name: my-cluster
      number: 8091

My question is, how do I get my-cluster?

This is my deployment

NAME                           READY   UP-TO-DATE   AVAILABLE   AGE
couchbase-operator             1/1     1            1           6h41m
couchbase-operator-admission   1/1     1            1           6h41m

This is service

NAME                           TYPE        CLUSTER-IP      EXTERNAL-IP   PORT(S)                                                                                                                         
cb-example                     ClusterIP   None            <none>        4369/TCP,8091/TCP,8092/TCP,8093/TCP,8094/TCP,8095/TCP,8096/TCP,9100/TCP,9101/TCP,9102/TCP,9103/TCP,9104/TCP,9105/TCP,9110/TCP,9111/TCP,9112/TCP,9113/TCP,9114/TCP,9115/TCP,9116/TCP,9117/TCP,9118/TCP,9120/TCP,9121/TCP,9122/TCP,9130/TCP,9140/TCP,9999/TCP,11207/TCP,11209/TCP,11210/TCP,18091/TCP,18092/TCP,18093/TCP,18094/TCP,18095/TCP,18096/TCP,19130/TCP,21100/TCP,21150/TCP   6h40m
cb-example-srv                 ClusterIP   None            <none>        11210/TCP,11207/TCP                                                                                                             
couchbase-operator             ClusterIP   <none>        8080/TCP,8383/TCP                                                                                                               
couchbase-operator-admission   ClusterIP     <none>        443/TCP                                                                                                                         
kubernetes                     ClusterIP      <none>        443/TCP                                                                                                                         

This is my pods

NAME                                           READY   STATUS    RESTARTS   AGE
cb-example-0000                                1/1     Running   0          6h42m
cb-example-0001                                1/1     Running   0          6h41m
cb-example-0002                                1/1     Running   0          6h40m
couchbase-operator-5684d55fb4-mf9hj            1/1     Running   0          6h44m
couchbase-operator-admission-b48bd65b8-jjk4q   1/1     Running   0          6h44m

So, i didnt see any my-cluster in service. I aslo have tried using cb-example and cb-example-srv in ingress, and it is not working

I’m not an expert here, but the srv is what the sdk uses to lookup the node addresses when the enable-srv-lookup is set.

Point your ingress at the cb-example service. That should give you access.

i tried before, it is not working.

May I know what happens when you try http://localhost/ui/index.html on browser?
Also, what does your ingress controller logs says when you do the req?