Couchbase AMI on Amazon Web Services. Crashing


I’m pretty new to Couchbase, I’ve installed a demo server on my MBP and I’m interacting with that, both through the web interface and via the java sdk without any issues.

I’ve now created an instance of Couchbase server on Amazon EC2 using the Couchbase AMI detailed here:

Note, I’m only using a t1.micro at this stage to take advantage of the free tier.

The instance starts up and appears to run absolutely fine. I then assigned an elastic IP to the instance and continued to interact through the web interface without any issues.

I installed the beer-sample bucket and can view documents ok. I added another bucket which worked ok but my problems started when I tried to add a document to the new bucket. First of all it takes quite a while to add the document and then when it finally does add the doc, the server crashes when I try to view it.

Once I restart the server via “sudo /etc/init.d/couchbase-server start” and attempt to interact with the beer-sample bucket, it becomes intermittent. Sometimes works, other times it just crashes the server again. This behaviour continues until I reboot the entire EC2 instance. Once rebooted, I can appear to interact with beer-sample but accessing the documents in my new bucket causes a crash.

Any ideas what could be causing this?

Is it just a resource issue i.e. the t1.micro server just doesn’t have the resources to cope?

Any pointers would be much appreciated.



The t1.micro is most of the time too small to really work properly with Couchbase, it is probably better to start with m1.large.

However, do you have any information in the log that could explain the crash?


Hi Tug,

Thanks for coming back to me.

Here is the last message sent to the error.1 file before the server crash:

[ns_server:error,2013-08-06T13:45:45.270,ns_1@<0.12842.0>:ns_janitor:cleanup_with_states:92]Bucket “lee-test-bucket” not yet ready on [‘ns_1@’]
=========================SUPERVISOR REPORT=========================
Supervisor: {local,menelaus_sup}
Context: child_terminated
Reason: {noproc,
Offender: [{pid,<0.12960.0>},

Does that help to understand why it might be crashing at all? I’ll take a look at using m1.large in the meantime to see if I experience similar behaviour.

It would be a shame if it is simply a resource issue and Couchbase doesn’t run at all on the t1.micro instance because that would allow people to take advantage of the AWS free tier for a period of time. Plus Amazon advertise it as “Free Tier Usage Eligible” on the Couchbase AWS Marketplace page which isn’t strictly true if it doesn’t run at all on the t1.micro instance.

Let me know if I can provide any more information to help work out why it’s happening.


Hmm it really looks like a resource issue, the message

Bucket “lee-test-bucket” not yet ready on [‘ns_1@’]

makes me think that the server has not finished initializing the bucket properly.

Hi Tug,

Yes I created an m1.small instance and that seemed fine, although I doubt it would be fine for long under any kind of load. But at least it stayed up long enough for me to access some documents.

Amazon do display Couchbase as free tier eligible so maybe there should be a message added somewhere in the AWS marketplace stating that Couchbase can’t actually run at all on the t1.micro instance because of insufficient resources. Just to save people trying to spin up a quick, free server for testing etc and then not being able to do anything without causing a crash.

Incidentally I also attempted to setup Couchbase on a Digital Ocean VMS. I had similar results as the t1.micro on AWS when trying to use their base package ($5/MO, 512MB RAM, 20GB). However running on the next package up installed and could be accessed for my testing purposes just fine ($10/MO, 1GB RAM, 30GB).

Anyway, hopefully someone will find this useful if trying to install on AWS or Digital Ocean. Thanks for your help.