Connection refuse 4984 port couchbase lite

4984 port is not working . Sync_gateway service can start or stop . But when i send request from browser ,it says connection refuse, This site can’t be reached . Can you please explain what is the problem ?

Hi @jislam150,

Where is Sync Gateway hosted? (locally or cloud (aws etc)?) and is there any proxy in front of the Sync Gateway?
Can you paste the link to the instructions you followed to install Sync Gateway?
Finally, could you add the “Sync Gateway” tag to this question to make it more visible to the team.


i can start service and also stop it . But when i call from browser with my ip:4984/db ,then i found connection refuse . My config.json file

"log": ["*"],
"databases": {
"db": {
  "server": "http://myip:8091",
  "bucket": "default",
  "users": { "GUEST": { "disabled": false, "admin_channels": ["*"] } }

The config file looks good. So either the service appears to be running but actually Sync Gateway is failing to start or there is some kind of networking configuration that prevents external access to the port.

Can you access the endpoint from within the VM where Sync Gateway is running? (curl -vX GET 'http://localhost:4984')


try adding the following top level property to your config.json file:


That will bind to port 4984 on all network interfaces not just the (localhost) interface.