Configuration parameter override in index FTS

Hello Couchbase friends. I have a problem with the parameter setting to increase the size of the number of documents returned by the FTS indexes (bleveMaxResultWindow).

When I modify it with via REST API like this:

curl -XPUT -H "Content-type: application / json" http: // <username>: <password> @ <ip>: 8094 / api / managerOptions -d '{"bleveMaxResultWindow": "999999999"}'

When the cluster had only one node, it worked fine. But when adding 2 more nodes to the cluster, the default configuration values are taken which is 10,000

I already tried putting environment variable

CBFT_ENV_OPTIONS = bleveMaxResultWindow=999999999

but it doesn’t work either.

According to the documentation it seems that this parameter is to configure the node, but the cluster configuration overwrites the parameter with the default value.

Couchabse 6.6.0 Community
Ubuntu 20 OS
1 cluster, 3 nodes

hi @nelsonxx1,

I suppose the default configuration works on the original node and the newer nodes don’t have this override in effect?
If so, this is an issue that we have addressed in the latest server release.

The workaround in older releases would be - update the value just one more time in any node in the cluster after all the rebalance operations are finished.

Let us know the outcome here.

Aside, all FTS related queries are faster answered if you post those in the respective forum here.


Thanks @sreeks for responding. Perform the tests as you mentioned and effectively worked. But it happens that when you restart or swing, you have to rerun the command to reconfigure the parameter again.

CouchBase version 7.0 has been fixed this problem? Version 7.0 is compatible with Python’s SDK 3.1?

Couchbase 6.6.0 Community
Ubunto 20 SO
1 cluster, 3 nodos