Cbbackupmgr restore unable to restore

Hi All,

I am trying to backup data from one cluster to another cluster using cbbackupmgr backup and restore command, in this context i was able to take backup and when i am trying to restore i am facing issue. Can anyone please help me to solve this.
I am using the command
/opt/couchbase/bin/cbbackupmgr restore -a /home/tmp -r example couchbase:// -u Admin -p Test
and post running this i am getting error
Error restoring cluster: data range at ‘/home/tmp/test/example/2023-08-22T12_45_15.309286427Z/homerload-f2b59f9fc1930fd43c4a0d14c8af89e1/range.json’ not found
I tried with multiple filters but didnt work.

Hi Mohan,

I see you are facing an issue with restoring a backup. The range.json file represents the location where ‘cbbackupmgr’ stores the sequence number ranges at the vBucket level. Could you please provide me with the following information which could help us find your issue?

  1. What is the Couchbase version the cluster is running that has been backed up, what version is being restored and which versions of cbbackupmgr are being used?
  2. What is the full backup command you are using?
  3. What do you mean by multiple filters ‘I tried with multiple filters but didnt work.’?
  4. If you can collect logs, link to documentation, we can further debug your issue.

Thank you,
Nour Elmenyawi

Hi nour,

I was able to backup from server 1 and we have installed couchbase version Community Edition 7.2.0 build 5325 and trying to restore in another server with version Community Edition 7.0.1 build 6102. The filters was specifying bucket name and start/end time , i have added all the commands i have tried to restore.
/opt/couchbase/bin/cbbackupmgr restore -a /home/abc/test/ -r example -c -u Abc -p 12345 --start 2023-08-22T12_45_15.309286427Z --end 2023-08-22T12_45_15.309286427Z --disable-eventing --continue-on-cs-failure
/opt/couchbase/bin/cbbackupmgr restore --archive /home/Abc/test -r example -c couchbase:// -u Abc -p 12345

Hi Mohan,

Thank you for providing the details for the versions. The current behaviour you are seeing is expected as it is currently not supported, this is because the range.json file was introduced in a later version than 7.0.x which as a result fails when restoring a newer backup on an older version.

We realise this is not obvious at the moment but it was addressed in 7.1.x in MB-49601. The workaround for this error is to perform the restore using a 7.2.x version of cbbackupmgr.

Hope that helps address your issue, if you have any more questions please let me know.

Thank you,
Nour Elmenyawi