Cbbackup Out of memory error

We are backing up couchbase bucket with 7.7 million documents.
after 16% progress it ran out of memory:
$ dmesg | grep Kill
[71682227.131776] Out of memory: Kill process 12189 (python) score 833 or sacrifice child
[71682227.330822] Killed process 12189 (python) total-vm:21796864kB, anon-rss:6363680kB, file-rss:0kB

command used:
$ ./cbbackup http://100.880.20.80:8091 /home/backups/defaultBucket -u -p -b default

What could be the reason ?

I ran into the same issue, I think there is an open ticket for this somewhere if you google it or search these forums. I was able to do a straight file backup without having any memory issues or affecting the running couchbase instance by using this command:

sudo /opt/couchbase/bin/cbbackup couchstore-files:///couchbase/data /db_backup -u <couchbase username> -p <couchbase password>
1 Like

Hi yes the issue logged is https://issues.couchbase.com/browse/MB-14833

Thanks everyone for suggestions. This is what worked for me.
/opt/couchbase/bin/cbbackupwrapper /Data/Backup -u yyyyy -p xxxxx -b bkt --path /opt/couchbase/bin/ --sequential -n 1024 -x cbb_max_mb=50000,batch_max_bytes=16000000,batch_max_size=5000