CB-7.x-beta & N1QL/FTS error

I have CouchBase-7.0-beta running and trying to do this query below with N1QL & Full text search. I’m getting this error.


  "explain": true,
  "fields": [
  "highlight": {},
  "query": {
    "query": "texas"
}) as b


    "code": 5010,
    "msg": "Error evaluating ExpressionScan. - cause: Issue with accessing node information for rest endpoint nodesExt - cause: nodesExt"

I have this below already set.

Try to use SEARCH() function. SEARCH_QUERY() never documented and will be deprecated.

I looked up docs and blogs below.

This link on SEARCH() : Search Functions | Couchbase Docs
This Blog on N1QL: Introducing Full-Text Search Capability via the Query Interface - DZone Database

I’m still not able to SEARCH … I have the: bucket name , picking _default collection , query string, FTS index name. This is very confusing.

query_context is is set bucket snake, scope _default, so, snake is consider as collection.

Option 1: Remove query_context (above screen shot top right corner ) list boxes.

Option 2: Use full path of default collection
SELECT * FROM snake._default._default AS s


Looks like the query is not pathing to the Bucket correctly.

Here is the bucket info BELOW

Did you use keyword analyzer. cc @abhinav
OR try this

SERACH(s, {"query": {
    "query": "texas"
  }}, {"index":"snakeFull"});

Worked … Looks like the FTS index snakeFull was hung at 11.5% completed for days so N1QL was not able to find the FTS index… Dropped the snakeFull index recreated to 100% …Works.

1 Like

@vsr1 … Could have debugged it sooner if N1QL error said something about FTS index scan error(s).

If Index is not 100% built, it is not consider (i.e. as of index not exist) online/ready to use (because it result in wrong results). N1QL is query and can’t return wrong results, so it validate the index with query. If validation fails it will not use that index.
It will try to use GSI index or other indexes. As none of them present it gives the error saying index is not present.

1 Like