CAPI (port 8092) return "Connection refused" after Couchbase Server upgrade 5.0.1 -> 5.1.1 CE

Hi everyone!

Yesterday I tried to update Couchbase Server from version 5.0.1 to 5.1.1 (both community edition) but the process failed. The database was online and worked without issues until I tried to resume XDCR. Then it failed multiple times on the second cluster (broadcaster) showing “error” in XDCR tab but without details.

I figured out it has to do something with networking then and started digging. Then I noticed I’m unable to query port 8092 - capi which is responsible for “Views and XDCR access”. The response was “Connection refused”. I tested the same thing on other cluster with 5.0.1 - the response was HTML.

For some reason service capi is not working in version 5.1.1. Please check it.

Second issue - I was unable to rollback from 5.1.1 to 5.0.1 easily. Couchbase Server was completely down when I used the same volume in 5.0.1. I guess it has something to do with config that was already upgraded by 5.1.1. It would be good to have backwards compatibility when it comes to minor releases like this one.




I did the same thing today with the enterprise edition and ran into the same problem. (with the official docker images)
I tracked it down to the lastest docker image for 5.1.1 which was change 6 days ago.

In the /opt/couchbase/etc/couchdb/default.d/capi.ini file there is the port for CAPI missing.

I also rolled back to 5.1.0 because of this error.

btw: I have another cluster with 5.1.1 which was installed more than 7 days ago and in this docker image everything seems ok.

Good to know that I’m not the only one with this issue :smiley: at least.
Does anyone know if there’s an issue in Couchbase JIRA? Any news when the fixed version will be released again?

This issue persists. @geraldss @avsej

We are having the same issue.

Upgraded one cluster to 5.1.1 using the enterprise-5.1.1 tagged image from Docker hub, everything seems to be working fine. Spun up a new dev cluster over the past few days and we’re unable to create our views because 8092 is throwing a connection refused and the port line is blank in capi.ini.

UPDATE: Turns out the Docker Hub repo couchbase:enterprise-5.1.1 works, but couchbase/server:enterprise-5.1.1 does not.

Rebuilt my entire cluster on couchbase:enterprise-5.1.1 and had no issues creating spacial views.

1 Like

@mtrossbach awesome investigation into this issue!

I’ve investigated further and raised to get this issue fixed.

Hope this helps!

In terms of why couchbase/server was broken but not couchbase.

The official couchbase repos are only updated on new releases, whereas the automated builds as part of couchbase/server are updated often (and sometimes regenerated).

In the meantime the best solution is to use the official dockerhub images :slight_smile: