Backup failing if there are Multiple repo pointing to the shared ARCHIVE location

Hello - I am trying to do a weekly full backup and incremental in for the other days, the logic i am doing is creating a new ARCHIVE at /data location with that i am dynamically appending the date when the full backup is taken,
so it looks like /data/Aug-12-21019 and next week it will automatically create /data/Aug-19-2019 and so on …when i tried doing this i am getting this below error which is not much informative and would like to see if this approach is possible or not, suggestions plz

[ERROR] panic: runtime error: slice bounds out of range
** [-][ERROR] 
** [-][ERROR] goroutine 1 [running]:
** [-][ERROR], 0x3c, 0xc420056c9e, 0x1e, 0x6, 0x0, 0x0)
** [-][ERROR] 	/home/couchbase/jenkins/workspace/couchbase-server-unix/goproj/src/ +0x278
** [-][ERROR], 0x1d, 0xc42010779a, 0x3, 0x3, 0x0, 0x0)
** [-][ERROR] 	/home/couchbase/jenkins/workspace/couchbase-server-unix/goproj/src/ +0x3f4
** [-][ERROR], 0x19, 0xc42010766e, 0xb, 0x5, 0x0, 0x0)
** [-][ERROR] 	/home/couchbase/jenkins/workspace/couchbase-server-unix/goproj/src/ +0x351
** [-][ERROR], 0xd, 0x0, 0x0, 0x1, 0x735779)
** [-][ERROR] 	/home/couchbase/jenkins/workspace/couchbase-server-unix/goproj/src/ +0x41a
** [-][ERROR], 0xd, 0x80d600, 0x9, 0x80bb01, 0x4)
** [-][ERROR] 	/home/couchbase/jenkins/workspace/couchbase-server-unix/goproj/src/ +0x94
** [-][ERROR] main.(*BackupContext).Run(0xc4200dbb80)
** [-][ERROR] 	/home/couchbase/jenkins/workspace/couchbase-server-unix/goproj/src/ +0xaf
** [-][ERROR] main.(*BackupContext).Run-fm()
** [-][ERROR] 	/home/couchbase/jenkins/workspace/couchbase-server-unix/goproj/src/ +0x2a
** [-][ERROR]*Command).parseFlags(0xc4201242a0, 0xc42009f830, 0xc420010430, 0xb, 0xb)
** [-][ERROR] 	/home/couchbase/jenkins/workspace/couchbase-server-unix/godeps/src/ +0x394
** [-][ERROR]*Command).parse(0xc4201242a0, 0xc42009f830, 0xc420010430, 0xb, 0xb)
** [-][ERROR] 	/home/couchbase/jenkins/workspace/couchbase-server-unix/godeps/src/ +0x10a
** [-][ERROR]*Command).parseCommands(0xc420124b60, 0xc42009f830, 0xc420010420, 0xc, 0xc)
** [-][ERROR] 	/home/couchbase/jenkins/workspace/couchbase-server-unix/godeps/src/ +0x32c
** [-][ERROR]*Command).parse(0xc420124b60, 0xc42009f830, 0xc420010420, 0xc, 0xc)
** [-][ERROR] 	/home/couchbase/jenkins/workspace/couchbase-server-unix/godeps/src/ +0x13f
** [-][ERROR]*CLI).Parse(0xc42011e090, 0xc420010410, 0xd, 0xd)
** [-][ERROR] 	/home/couchbase/jenkins/workspace/couchbase-server-unix/godeps/src/ +0x1cc
** [-][ERROR] main.main()
** [ ][ERROR] 	/home/couchbase/jenkins/workspace/couchbase-server-unix/goproj/src/ +0x8f6f

Hello @diggerlearner,

To be able to help you, we require few more details:

  • What versions of Couchbase Server are you using?
  • Are the files and directories being edited out side of cbbackupmgr?
  • Can you share the script/code snippet that is being used to control cbbackupmgr


Thanks ,
CB version -5.0.1
NO edit has been performed on directories/file level.
for point no.3 i did this in 2 steps.
First i went on one of the box and ran config to create one repo “test”
and than i ran an automaton script attached below , where i got an error

start_week=date +"%b-%d-%Y" -d
last_week=date +"%b-%d-%Y" -d
CB_INSTALL_DIR- MY binary location
CB_ARCHIVEis /data/{start_week} sudo {CB_INSTALL_DIR}/bin/cbbackupmgr config -a {CB_ARCHIVE} --repo test sudo {CB_INSTALL_DIR}/bin/cbbackupmgr backup -a ${CB_ARCHIVE} --repo test --cluster host_ip

Any suggestions here,plz