Auto delete of documents

Hi, I´m working with the version 4.0 of CouchBase.

When I put documents into the Bucket the documents are deleted automatically, if the setup of ttl is 72hrs the documents are deleted on the period of 3 minutes.

What I need setup for avoid that the documents be deleted automatically???

If you don’t set a TTL (or depending on the SDK, set a TTL of zero) then the documents will not be automatically deleted.

Thanks Drigby, the issue was that i was setting a ttl of 7260601000 as milliseconds, then this value is higher than 30246060 and CouchBase take it as timestamp.