Analtical queries

hello i had to run queries on analytical service using workbench

On data set with 16 buckets. i had uploaded them using local link to datasets but

first i had the that error message when i try to connect data set

Error connecting/disconnecting link. Got status: 500 from server.[{“code”:22001,“msg”:"Connect link failed {“Default.Local.observations” : “Maximum number of active writable datasets (8) exceeded”, “Default.Local.organizations” : “Maximum number of active writable datasets (8) exceeded”, "D…

second when try try to perform join query it give me empty result but it it give me result for query for connected data sets

could any one help me

can any one help me why it didnt connect more than 8 dataset using loacal link

Hi @Aya_Gamal,
By default, the Analytics service supports 8 writable datasets (i.e. actively ingesting data from buckets). You need to change that default configuration to a value at least equivalent to the number of datasets you are using (e.g. 16).
To do that, you need to do the following:

  1. Use the Analytics service configuration API to change the parameter storageMaxActiveWritableDatasets (e.g.):
curl -v -u Administrator:password -X PUT -d storageMaxActiveWritableDatasets=16 http://localhost:8095/analytics/config/service
  1. Restart the Analytics service for the change to take effect:
curl -v -u Administrator:password -X POST http://localhost:8095/analytics/cluster/restart

After that, you should be able to connect the link successfully.
You can find more details about the Analytics configuration API here.

As for the empty results when performing the join query, you got no result because the datasets didn’t ingest any data due to the link failing to connect. Once you change the configuration and restart the service, the link should be connected successfully and you should start seeing results in the query.

1 Like

many thanks , should i add analytics server node before i change the configuration

The Analytics service should be running to change the configuration. So, if you have no Analytics nodes in the cluster at all, you should add at least one before attempting to change the configuration.