AmbiguousTimeoutException TIMEOUT "retryReasons":["COLLECTION_NOT_FOUND"]

java client 3.1.5
couchbase server 7.0 beta .

imported travel-sample bucket and inventory scope and collections .
When try to insert json to hotel collection getting below exception,
Caused by: com.couchbase.client.core.error.AmbiguousTimeoutException: InsertRequest, Reason: TIMEOUT {“cancelled”:true,“completed”:true,“coreId”:“0xa3fa806900000001”,“idempotent”:false,“lastChannelId”:“A3FA806900000001/000000002450FD2D”,“lastDispatchedFrom”:“”,“lastDispatchedTo”:“localhost:11210”,“reason”:“TIMEOUT”,“requestId”:110,“requestType”:“InsertRequest”,“retried”:19,“retryReasons”:[“COLLECTION_NOT_FOUND”],“service”:{“bucket”:“travel-sample”,“collection”:“hotel”,“documentId”:“hote-2001”,“opaque”:“0x81”,“scope”:“inventory”,“type”:“kv”},“timeoutMs”:5000,“timings”:{“encodingMicros”:4181,“totalMicros”:5009266}}
at com.couchbase.client.core.msg.BaseRequest.cancel(
at com.couchbase.client.core.Timer.lambda$register$2(
at java.base/
Suppressed: java.lang.Exception: #block terminated with an error
at reactor.core.publisher.BlockingSingleSubscriber.blockingGet(
at reactor.core.publisher.Mono.block(
Tried printing collections
ReactiveCollectionManager mgr = reactiveBucket.collections();

  •   	mgr.getAllScopes().toIterable()*
  •   			.forEach(ss -> ss.collections().stream().forEach(cs -> System.out.println(;*

below collections are getting printed

  1. if try to insert into _default collection ,its working fine . json doc inserted successfully with _default scope and _default collection .
    below code used to insert json doc:
    ReactiveCollection reactiveCollection = reactiveBucket.scope(scopeName).collection(collection);
    JsonObject content = …
    reactiveCollection.insert(docId, content).block()

Hello @selvarajc welcome to the forum post.

For the purpose of testing with Couchbase Server 7.0 Beta you might want to downgrade to Java SDK 3.1.3 instead.
The reason being that there were some server level API changes made recently ( thats not made publicly available yet, refer to the MB-44807) , however the most recent SDK versions have the changes baked in an effort to support those changes and hence the error.
Every thing should align once Couchbase server goes GA. Thanks for checking and let us know if it worked.

Thanks have downgraded sdk version from 3.1.5 to 3.1.3 and it worked .