Outdated attrs requirement

Hi there! The python client chouchbase 3.2.7 depends on attrs~=19.1 which is terribly old and interferes with some other requirements in my project. Could you upgrade attrs to a more recent version, preferably >=21.2.0?


@Valentin_Stauber Python SDK 4.0 did recently ship and with that, we no longer depend on attrs.


Thanks @biozal. Also note @Valentin_Stauber that 4.0 is intended API compatible with 3.x. The main reason for the major version bump is to signal that there were significant internal changes. Generally we’d recommend moving to 4.x unless your testing shows some reason you cannot, in which case we’d like to know what that is to fix it. See the release notes for some more info.

1 Like

I see. Upgrading to 4.0 will trigger another upgrade cycle with necessary testing, which we can’t afford currently. In due time we will do that. In the meantime, would it be worthwhile to consider releasing a 3.2.8 version with attrs>=19.1?