Errors in indexer and projector logs

I am unable to create an index.
There are errors in the logs.
This is a fresh installation of 5.1.1
Had the same problems with 5.0.1

I have made sure Couchbase ports are available by changing the service start options to “manual”, restarting my laptop, running netstat -ab and searching for all the ports on the list while Couchbase is stopped.
None of them showed up.
After starting Couchbase, I can see that the ports are in use by the indexer and projector (13.1 KB)

@alon.schachter It seems there is another forum post (Changing port mapping) where you mentioned the issue is resolved. Could you please confirm? Thanks, Jeelan

The issue on this post isn’t resolved.
On the other post is was resolved.


Are you referring to below errors:

2020-07-12T13:54:37.482+03:00 [Error] KVSender::sendShutdownTopic Unexpected Error During Shutdown Projector Topic MAINT_STREAM_TOPIC_40d39b5e500da12e309e30c331ecf963. Err projector.topicMissing

These errors are expected and do not hinder the functionality of projector/indexer. The first request from indexer to projector will error out because projector knows nothing about the indexer yet. Hence, it responds with topicMissing error.

If you are referring to other errors, please let us know.


@varun.velamuri I am referring to the fact that I’m unable to create an index.
I’m getting “unexpected server error” from the Couchbase console.

@alon.schachter, I don’t see this error in indexer.log. Can you try restarting the query process (cbq-engine). If the problem persists, can you share the corresponding query.log?


These types of errors which are in the indexer.log are not related?

2020-07-12T14:11:25.911+03:00 [Error] receiving packet: read tcp> wsarecv: An existing connection was forcibly closed by the remote host.

2020-07-12T14:11:25.911+03:00 [Error] [Queryport “:9101”] connection “” exited read tcp> wsarecv: An existing connection was forcibly closed by the remote host.

Regarding the query log, there are no errors there.
I don’t even see the index creation request in the query log

@alon.schachter, These errors are related. Hence, I have asked for cbq-engine restart. These errors are network errors. Looks like indexer is unable to connect to the query process or the query process is crashing.

Which version of couchbase-server are you using? Is there a network partition between query node and rest of the cluster. Can you try index creation using cbq shell (


I tried it with CB 5.01 , 5.1.1, 6.5.1
There is no cluster.
Just 1 node on my windows 10

I don’t know what it means to restart cbq, but I restarted the Couchbase service many times and reinstalled the whole thing many times.

As for the cbq shell, it’s not really cooperating with me.

I ran cbq -u=administrator -p=my password
pressed enter

then pasted the index create sql line and pressed enter.
it didn’t do anything.
just shows another prompt.


Query log is attached (76.9 KB)

@alon.schachter, Apologies. The cbq shell seems to require query service to be in the cluster. From the query logs, I see that query process is crashing frequently. Hence cbq might not be much of use.

[goport(c:/Program Files/Couchbase/Server/bin/cbq-engine)] 2020/07/15 16:29:58 child process exited with status 3221226505

@vsr1 Any ideas on the reason behind this exit message. The exit status seems weird.

@marcog Would be great if you can take a look.

3221226505 is 0xc0000409, which maps to STATUS_STACK_BUFFER_OVERRUN.
It strikes me as a golang runtime issue where the P windows stack has been exceeded or overwritten.
I’m kind of surprised that we don’t get a panic and a stack in the log.
Are we saying that this happens in 6.5 as well?

I was having the same issue in 6.5
I didn’t look at the query log of 6.5
If you want I can send 6.5 logs

yeah, that’d be useful 'cause I can’t believe that 5.x and 6.5 are failing in the same way…


Theses are the logs from 6.5.1 after failing to create an index. (9.5 KB)