[RCBC-66] Ruby Gem 1.1.2/1.1.3 not responding to :node_list param in Couchbase.new||Couchbase.connect Created: 30/Jul/12  Updated: 13/Jan/14  Resolved: 11/Jun/13

Status: Closed
Project: Couchbase Ruby client library
Component/s: docs, library
Affects Version/s: 1.1.2
Fix Version/s: None
Security Level: Public

Type: Bug Priority: Major
Reporter: Jasdeep Jaitla Assignee: Sergey Avseyev
Resolution: Won't Fix Votes: 0
Labels: None
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified
Environment: I tried it on Amazon Linux with a cluster of two Couchbase 2.0 build 1495's specifying gem versions.


 Description   
:node_list syntax returning:
Connection failed: Connection refused (error=0x17) (Couchbase::Error::Connect)

Direct connection to each node works fine. It also works fine in 1.2.0dp6.

See thread for more info: http://www.couchbase.com/forums/thread/ruby-client-connection-refused-using-nodelist
I confirmed it wasn't working.

 Comments   
Comment by Jasdeep Jaitla [ 30/Jul/12 ]
I tried it in both 1.1.2 and 1.1.3, neither worked. Like I said, it does work in 1.2.0dp6 latest release. Of course I also have a newer libcouchbase (the one required for dp6 of gem).
Comment by Sergey Avseyev [ 31/Jul/12 ]
I thought its kind of feature, not a bug therefore shouldn't be merged into stable branch. there is workaround although. User could create array of hosts and shift and try host checking for connect error
Comment by Jasdeep Jaitla [ 01/Aug/12 ]
Ah, true, I think what is confusing is the docs on github show the syntax but it only works in dp gem... maybe just make a quick note about that?
Comment by Sergey Avseyev [ 02/Aug/12 ]
Could you put the link?
Comment by Sergey Avseyev [ 11/Jun/13 ]
We aren't backporting features to previous versions without escalation
Generated at Sun Apr 20 21:11:33 CDT 2014 using JIRA 5.2.4#845-sha1:c9f4cc41abe72fb236945343a1f485c2c844dac9.