[RCBC-105] Docs: What operating system versions does the ruby gem support? Created: 20/Dec/12  Updated: 13/Jan/14  Resolved: 13/Jan/14

Status: Closed
Project: Couchbase Ruby client library
Component/s: docs
Affects Version/s: 1.2.0
Fix Version/s: None
Security Level: Public

Type: Bug Priority: Major
Reporter: Perry Krug Assignee: Sergey Avseyev
Resolution: Fixed Votes: 0
Labels: None
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified


 Description   
I seem to be having problems installing this on CentOS 5.8. I'm not sure if that's the problem, but I tried to verify it via our documentation and couldn't find what versions were supported or not.

 Comments   
Comment by Sergey Avseyev [ 06/May/13 ]
couchbase ruby gem depends on ruby 1.8.7+ and libcouchbase (if there are issues with libcouchbase, please report to CCBC)

According to official ruby site ruby 1.9.3 is supported by centos 5 (probably not from official repository, but should work without any problems): https://bugs.ruby-lang.org/projects/ruby-trunk/wiki/SupportedPlatforms#Ruby-193
Comment by kzeller [ 06/May/13 ]
Please add this information to the correct part of the documentation set for Ruby.
Comment by Sergey Avseyev [ 13/Jan/14 ]
It should be obvious from getting started that ruby gem depends on libcouchbase, therefore works everywhere libcouchbase and one of the supported ruby interpreters installed
Generated at Mon Sep 22 15:03:48 CDT 2014 using JIRA 5.2.4#845-sha1:c9f4cc41abe72fb236945343a1f485c2c844dac9.