[PCBC-200] Docs: Documented supported versions of PHP Created: 11/Feb/13  Updated: 14/May/13  Resolved: 14/May/13

Status: Closed
Project: Couchbase PHP client library
Component/s: docs
Affects Version/s: 1.1.2
Fix Version/s: None
Security Level: Public

Type: Improvement Priority: Minor
Reporter: Perry Krug Assignee: kzeller
Resolution: Fixed Votes: 0
Labels: None
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified


 Description   
Previous pages of the /develop/PHP/current mentioned support for a specific PHP version. There is no mention of that now.

Does that imply that any version of PHP will work with any of our supported libraries? If yes, let's please be specific about that. If no, can we please detail which PHP version is supported for each OS?

 Comments   
Comment by Trond Norbye [ 02/Apr/13 ]
Can you update the documentation on the site that the currently supported versions is PHP 5.3 and newer.
Comment by kzeller [ 14/May/13 ]
confirmed/updated

getting-started.xml:47: <para> PHP 5.3 and above installed. For more information, see <ulink
tutorial.xml:43: PHP 5.3 or later: The PHP SDK itself requires 5.3 or later,

appears:

http://www.couchbase.com/docs/couchbase-sdk-php-1.1/getting-started.html
http://www.couchbase.com/docs/couchbase-sdk-php-1.1/tutorial.html
Comment by kzeller [ 14/May/13 ]
confirmed/updated

getting-started.xml:47: <para> PHP 5.3 and above installed. For more information, see <ulink
tutorial.xml:43: PHP 5.3 or later: The PHP SDK itself requires 5.3 or later,

appears:

http://www.couchbase.com/docs/couchbase-sdk-php-1.1/getting-started.html
http://www.couchbase.com/docs/couchbase-sdk-php-1.1/tutorial.html
Generated at Sat Aug 30 01:06:36 CDT 2014 using JIRA 5.2.4#845-sha1:c9f4cc41abe72fb236945343a1f485c2c844dac9.