[MB-4160] unable to change the admin(REST) port from 8091 Created: 05/Aug/11  Updated: 25/Oct/11  Resolved: 06/Sep/11

Status: Resolved
Project: Couchbase Server
Component/s: RESTful-APIs
Affects Version/s: 1.7.1
Fix Version/s: 1.7.2
Security Level: Public

Type: Bug Priority: Major
Reporter: Perry Krug Assignee: Aliaksey Artamonau
Resolution: Fixed Votes: 0
Labels: 1.7.1-release-notes
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified


 Description   
Neither of the following worked, although they both said success:
CLI:
/opt/membase/bin/membase cluster-init --cluster=10.1.3.100:8091 -u Administrator -p password --cluster-init-user=Administrator --cluster-init-password=password --cluster-init-port=8080
SUCCESS: init 10.1.3.100

REST API:
curl -d username=Administrator -d password=password -d port=8080 http://Administrator:password@10.1.3.100:8091/settings/web
{"newBaseUri":"http://10.1.3.100:8080/"}

presumably the underlying problem is with the REST API not doing what it's saying

 Comments   
Comment by Aleksey Kondratenko [ 11/Aug/11 ]
kind of fixed by http://review.couchbase.org/8719 (applied to branch-20)

But note that it'll change _current node_ port not entire cluster, so it's still not quite advertise-able.
Comment by Farshid Ghods (Inactive) [ 11/Aug/11 ]
Integrated in github-ns-server-2-0 #101 (See [http://qa.hq.northscale.net/job/github-ns-server-2-0/101/])
    MB-4160 Set rest port on per node basis.

Aliaksey Kandratsenka :
Files :
* src/ns_cluster.erl
* src/menelaus_web.erl
* src/menelaus_event.erl
Comment by Perry Krug [ 11/Aug/11 ]
Reopening this since the feature is still "broken" in a customer's eyes...it used to change the admin port for the whole cluster.
Comment by Aleksey Kondratenko [ 06/Sep/11 ]
fix merged to 1.7.2 branch
Comment by Aleksey Kondratenko [ 13/Sep/11 ]
merge to 2.0 in http://review.couchbase.org/9556
Comment by Farshid Ghods (Inactive) [ 25/Oct/11 ]
https://github.com/membase/ns_server/commit/bcf3b5b4cfd8b719de11dde19b7f5a5ccf8d587e
Generated at Thu Jul 10 10:22:04 CDT 2014 using JIRA 5.2.4#845-sha1:c9f4cc41abe72fb236945343a1f485c2c844dac9.