Couchbase Ruby client library

rb_sprintf() isn't available in ruby 1.8.7, so recent couchbase-ruby-client doesn't work there