Writing to a different bucket than default does not work

Hi.
I am using couchbase-client-1.0.2 and couchbase 2.1.1
When i try to connect and write to a bucket other then the one called "default"
it still writes to "default".
Here is the code i use to connect:

CouchbaseConnectionFactoryBuilder builder = new CouchbaseConnectionFactoryBuilder();
builder.setOpTimeout(LeadspaceProperties.getMemcachedOperationTimeout()).setProtocol(Protocol.BINARY).setHashAlg(DefaultHashAlgorithm.KETAMA_HASH);//.setMaxReconnectDelay(1);
CouchbaseConnectionFactory factory = builder.buildCouchbaseConnection(serverList, "test" e, user, psw);
CouchbaseClient client =  new CouchbaseClient(factory);
.....

please note that i am using a pool of clients, some to default and some to test.

Any idea what i am doing wrong?

thanks

1 Answer

« Back to question.

Hello,

Have you tried to update your Java SDK to the latest one? (1.2.2)
http://www.couchbase.com/communities/all-client-libraries

As you can see the 1.0.x is not supported with Couchbase 2.x

Regards
Tug
@tgrall

Thanks for the reply.
I am now trying to upgrade the couchbase client and spymemcached to:
couchbase-client-1.2.2
spymemcached-2.10.2
But for some reason I fail to connect now.
First, it seems like the psw is mandatory to the bucket - which was not before
and then if i set "" as psw, it
spymemcached-2.10.2,
I am getting this error:
Server returned HTTP response code: 401 for URL: http://dev17.HQ.LeadSpace.com:8091/pools
Seems like an authorization problem.

Any ideas? what has changed?
thanks

Actually i fixed that error by removing the user and adding password ""
However, now i get this problem:
java.lang.IllegalArgumentException: Reconfigurable cannot be null and must never be re-set to a new object at com.couchbase.client.vbucket.ConfigurationProviderHTTP.subscribe(ConfigurationProviderHTTP.java:31)

Seems like this was supposed to be fixed on this version:
http://www.couchbase.com/issues/browse/JCBC-375

But it is not.
Has anyone succeeded on connecting with the new client?
Any idea what to do with this error?
thanks, Michal