Unable to get keys during rebalance

I am seeing during a re-balance that keys are unavailable up to 40 seconds while they are moved. Is this normal? Is there anyway to have all the keys available all the time, 40 seconds is a long time? I am using the execute commands and the IOperationResult is not null but the statuscode, message, and exception all are.
Also is there anyway to distinguish between a server down and keys not available during a re-balance? I printed out all the values in the IOperationResult and they are the same in both situations. Our code needs to execute a failover immediately during real node failures.
I am running server 2.0.1 and the .net client 1.2.4. I tried with 1.2.6 and things were worse.

2 Answers

« Back to question.

This has always been an issue for us too, it never worked ok from versions 1.6 to 2.0 current. I can confirm it is still not fixed ( using php clients 1.1.2 and 1.1.5 with cb 1.8.1 and 2.0.1 on mixed setups )

« Back to question.

Hello,

Do you still have the problem?
Have you upgraded your system to the latest SDK and Server release?

I know that the SDK team has done some work, and still doing it around rebalance.

Regards
Tug
@tgrall

Tug,

I currently am testing with the updated client 1.2.9. I still see connection issue with retrieving keys. I noticed that the operation result now says "Pool is dead or disposed". Is that a reliable value as a status during a rebalance? Can it be used to indicate rebalance in progress so don't fail over?

Thanks,
Justin