PHP 5.2 support ?

I want to test Couchbase in my web application.
But I failed to install PHP API on my server.
The error message is shown below:

# /usr/local/bin/pecl install couchbase
Did not download optional dependencies: pecl/igbinary, use --alldeps to download automatically
pecl/couchbase requires PHP (version >= 5.3.0), installed version is 5.2.14
pecl/couchbase can optionally use package "pecl/igbinary"
No valid packages found
install failed

Is there any way to use Couchbase with PHP 5.2 ?

Thanks in advance!

Sungsoo Kim

The PHP SDK requires PHP 5.3 - see http://docs.couchbase.com/couchbase-sdk-php-1.1/.

PHP 5.2 is pretty old - it was released back in 2007 and php.net declared it end-of-life in 2011 - see http://www.php.net/releases/

1 Answer

« Back to question.

drigby is correct there in the comments. There are some features that preclude PHP 5.2 support.