npm install couchbase@0.1.0 fails on ubuntu 12.04

when i try to install the couchbase couchnode modul on ubuntu 12.04 (with the libcouchbase packages from http://packages.couchbase.com/ubuntu/couchbase-ubuntu1204.list installed before) it fails with the error:

$ npm install couchbase@0.1.0
...
/usr/include/libcouchbase/plugins/io/libuv/plugin-libuv.c:50:26: error: ‘UV_RUN_ONCE’ undeclared (first use in this function)
...
gyp ERR! build error
...

trying the same with the libcouchbase packages installed manually with the latest from https://github.com/couchbase/libcouchbase works fine. the npm install succeeds.

is this a bug? or is couchnode just not working with the libcouchbase packages from the couchbase ubuntu repositories

regards philipp

its fixed with libcouchbase 2.1.3! thx.
since libcouchbase 2.1.3 is in the couchbase package repositories npm install of couchnode 0.1.0 works fine

1 Answer

« Back to question.

Happy to see that you have solved your issue.
Note that we have published the first official release of the node Couchbase drive 1.0.0.

Regards
Tug
@tgrall