The issue about installing libcouchbase

According to the Web site as below, I can't complete the installation on the title.
http://www.couchbase.com/develop/c/current

step1)
shell> sudo wget -O/etc/yum.repos.d/couchbase.repo http://packages.couchbase.com/rpm/couchbase-centos62-i686.repo
-> I confirmed "/etc/yum.repos.d/couchbase.repo". I have no problem.

step2)
sudo yum check-update
-> I thought I have also no problem.
-----------------------------------------------------------------------------------------------------------------------------------------
Loaded plugins: fastestmirror, refresh-packagekit, security
Repository couchbase is listed more than once in the configuration
Loading mirror speeds from cached hostfile
* base: ftp.iij.ad.jp
* extras: ftp.iij.ad.jp
* updates: ftp.iij.ad.jp

bash.i686 4.1.2-15.el6_4 updates
coreutils.i686 8.4-19.el6_4.2 updates
coreutils-libs.i686 8.4-19.el6_4.2 updates
curl.i686 7.19.7-37.el6_4 updates
e2fsprogs.i686 1.41.12-14.el6_4.2 updates
e2fsprogs-libs.i686 1.41.12-14.el6_4.2 updates
firefox.i686 17.0.7-1.el6.centos updates
glibc.i686 2.12-1.107.el6_4.2 updates
glibc-common.i686 2.12-1.107.el6_4.2 updates
glibc-devel.i686 2.12-1.107.el6_4.2 updates
glibc-headers.i686 2.12-1.107.el6_4.2 updates
glx-utils.i686 9.0-0.8.el6_4.3 updates
gnutls.i686 2.8.5-10.el6_4.2 updates
gzip.i686 1.3.12-19.el6_4 updates
iputils.i686 20071127-17.el6_4 updates
irqbalance.i686 2:1.0.4-4.el6_4 updates
kernel.i686 2.6.32-358.14.1.el6 updates
kernel-devel.i686 2.6.32-358.14.1.el6 updates
kernel-firmware.noarch 2.6.32-358.14.1.el6 updates
kernel-headers.i686 2.6.32-358.14.1.el6 updates
kexec-tools.i686 2.0.0-258.el6_4.2 updates
krb5-libs.i686 1.10.3-10.el6_4.4 updates
libcom_err.i686 1.41.12-14.el6_4.2 updates
libcurl.i686 7.19.7-37.el6_4 updates
libnl.i686 1.1.4-1.el6_4 updates
libss.i686 1.41.12-14.el6_4.2 updates
mdadm.i686 3.2.5-4.el6_4.1 updates
mesa-dri-drivers.i686 9.0-0.8.el6_4.3 updates
mesa-dri-filesystem.i686 9.0-0.8.el6_4.3 updates
mesa-libGL.i686 9.0-0.8.el6_4.3 updates
mesa-libGLU.i686 9.0-0.8.el6_4.3 updates
module-init-tools.i686 3.9-21.el6_4 updates
net-snmp.i686 1:5.5-44.el6_4.2 updates
net-snmp-libs.i686 1:5.5-44.el6_4.2 updates
python.i686 2.6.6-37.el6_4 updates
python-libs.i686 2.6.6-37.el6_4 updates
scl-utils.i686 20120927-2.el6_4.6 updates
selinux-policy.noarch 3.7.19-195.el6_4.12 updates
selinux-policy-targeted.noarch 3.7.19-195.el6_4.12 updates
tzdata.noarch 2013c-2.el6 updates
upstart.i686 0.6.5-12.el6_4.1 updates
vte.i686 0.25.1-8.el6_4 updates
xorg-x11-drv-mach64.i686 6.9.3-4.1.el6_4 updates
xulrunner.i686 17.0.7-1.el6.centos updates

-----------------------------------------------------------------------------------------------------------------------------------------

step3)
sudo yum install -y libcouchbase2 libcouchbase-devel
->But the errors occurred.

------------------------------------------------------------------------------------------------------------------------------------------
Loaded plugins: fastestmirror, refresh-packagekit, security
Repository couchbase is listed more than once in the configuration
Loading mirror speeds from cached hostfile
* base: ftp.iij.ad.jp
* extras: ftp.iij.ad.jp
* updates: ftp.iij.ad.jp
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package libcouchbase-devel.i686 0:2.0.7-1 will be installed
--> Processing Dependency: libcouchbase.so.2 for package: libcouchbase-devel-2.0.7-1.i686
--> Processing Dependency: libcouchbase2-core for package: libcouchbase-devel-2.0.7-1.i686
---> Package libcouchbase2.i686 0:2.0.7-1 will be installed
--> Processing Dependency: libcouchbase2-backend for package: libcouchbase2-2.0.7-1.i686
--> Running transaction check
---> Package libcouchbase2-core.i686 0:2.0.7-1 will be installed
---> Package libcouchbase2-libev.i686 0:2.0.7-1 will be installed
--> Processing Dependency: libev >= 3 for package: libcouchbase2-libev-2.0.7-1.i686
--> Processing Dependency: libev.so.4 for package: libcouchbase2-libev-2.0.7-1.i686
--> Finished Dependency Resolution
Error: Package: libcouchbase2-libev-2.0.7-1.i686 (couchbase)
Requires: libev >= 3
Error: Package: libcouchbase2-libev-2.0.7-1.i686 (couchbase)
Requires: libev.so.4
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
------------------------------------------------------------------------------------------------------------------------------------------

the circumstances
1) Cent OS 6.4(32bit) on VMware
2) The couchbase-server-community_x86_2.0.1.rpm was already installed.
3) Node.js was also installed.

I need support to go on my mission.

Best Regards.

1 Answer

« Back to question.

Hi,

I see error messages in your log when you tried to install libcouchbase:

Error: Package: libcouchbase2-libev-2.0.7-1.i686 (couchbase)
Requires: libev >= 3
Error: Package: libcouchbase2-libev-2.0.7-1.i686 (couchbase)
Requires: libev.so.4 - See more at: http://www.couchbase.com/communities/q-and-a/issue-about-installing-libcouchbase#sthash.XDorrnyH.dpuf

It says you need to install libev, it is required from libcouchbase.
In order to install libev, you need to install EPEL (Extra Packages for Enterprise Linux) like below:

rpm -Uvh http://ftp.riken.jp/Linux/fedora/epel/6/i386/epel-release-6-8.noarch.rpm

After that, please try installing libcouchbase again.

Many thanks!
According to your support I can complete the installation of libcouchbase.
I will continue my mission.

Correct, the libev 4 dependency has been recorded during build step. We are doing so, because stock libevent-devel and libev-devel conflict on centos, because libev-devel packaged incorrectly and trying to install /usr/include/event.h

If you don't need libcouchbase2-libev backend, you can install libcouchbase2-libevent explicitly and it will work without additional repository