Failed Installation on Ubuntu 10.04

Problem:
Couchbase 2.2.0 (or 2.1.1) installation fails on Ubuntu 10.04 with error: “Unable to load crypto library. Failed with error: load_failed, Failed to load NIF library”. Can you please help us to resolve the problem (details below). Thanks!

System settings:
System is a dedicated hosted virtual server (default Ubuntu 10.04 LTS version)
[root@CAKE ~]$ uname -a
Linux VPS-Machine 2.6.18-028stab101.1 #1 SMP Sun Jun 24 19:50:48 MSD 2012 x86_64 GNU/Linux
[root@CAKE ~]$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=10.04
DISTRIB_CODENAME=lucid
DISTRIB_DESCRIPTION="Ubuntu 10.04.4 LTS"
[root@CAKE ~]$ openssl version
OpenSSL 0.9.8k 25 Mar 2009
[root@CAKE ~]$ erl
Erlang R13B03 (erts-5.7.4) [source] [64-bit] [rq:1] [async-threads:0] [hipe] [kernel-poll:false]
Eshell V5.7.4 (abort with ^G)

Installation output:
[root@CAKE ~]$ dpkg -i couchbase-server-enterprise_2.2.0_x86_64_openssl098.deb
Selecting previously deselected package couchbase-server.
(Reading database ... 99161 files and directories currently installed.)
Unpacking couchbase-server (from couchbase-server-enterprise_2.2.0_x86_64_openssl098.deb) ...
libssl0.9.8 is installed. Continue installing
Minimum RAM required : 4 GB
System RAM configured : 4194304 kB
Minimum number of processors required : 4 cores
Number of processors on the system : 1 cores
Setting up couchbase-server (2.2.0) ...
Upgrading couchbase-server ...
/opt/couchbase/bin/install/cbupgrade -c /opt/couchbase/var/lib/couchbase/config -a yes
Automatic mode: running without interactive questions or confirmations.
Analysing...
Done: no previous config.dat found; nothing to upgrade.
* Failed to start couchbase-server: timed out
dpkg: error processing couchbase-server (--install):
subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
couchbase-server

Processes running after installation:
[root@CAKE couchbase]$ ps -ef | grep couch
998 1899 31816 90 15:14 ? 00:00:01 /opt/couchbase/lib/erlang/erts-5.8.5/bin/beam.smp …
998 31803 1 0 15:06 ? 00:00:00 /opt/couchbase/lib/erlang/erts-5.8.5/bin/epmd -daemon
998 31816 1 0 15:06 ? 00:00:01 /opt/couchbase/lib/erlang/erts-5.8.5/bin/beam ...

Log output (short version):
[root@CAKE couchbase]$ cat /opt/couchbase/var/lib/couchbase/logs/error.1
[error_logger:error,2013-10 28T15:06:53.594, nonode@nohost:error_logger<0.6.0>: ale_error_logger_handler:log_msg:76] Unable to load crypto library. Failed with error:
"load_failed, Failed to load NIF library: '/opt/couchbase/lib/erlang/lib/crypto-2.0.4/priv/lib/crypto.so: failed to map segment from shared object: Cannot allocate memory'"
OpenSSL might not be installed on this system.
--> But, OpenSSL 0.9.8k is installed (see system/installation output above)

Bugreports with similar problems:
http://www.couchbase.com/issues/browse/MB-4862 => Problem is marked as fixed, since only users for a migration from 1.8 to 2.0 on a Ubuntu 12 system with a newer OpenSSL version are affected

That's not same error. It's complaining about not being able to allocate memory.

If you remove /opt/couchbase/lib/ns_server/erlang/lib/mlockall/priv/mlockall_nif.so it might be able to succeed. But it's a sign of some memory shortage.

Do you have any swap configured ? Do you have any other services running on that box ?

Doing /opt/couchbase/cbcollectinfo will gather answers for all kinds of questions I might ask. So ideally I'd like you to give us output of that tool so that we can help you.

0 Answers

No answers yet