Does couchbase-cli work on Mac OS X 10.9 (I get an error)?

I can login and use the Administration console with the username and password I try to use on the command line. When I try the following command with Couchbase version 2.1.1 I get the error below:

command:
server> couchbase-cli server-info -c localhost:8091 -u xxxxx -p xxxxx
error:
ERROR: unable to access the REST API - please check your username (-u) and password (-p)

User name and password are correct.

Anyone seeing or have seen the same behavior? Any ideas?

Thanks.

1 Answer

« Back to question.

Hey there, not sure what is happening for you, but I just tested out 2.2 on my mavericks and it worked fine, are you positive you are getting your U/P right?

I am using 2.1.1. Will give 2.2 a try and see how it goes. Yes I am sure the U/P is right. I did a cut and paste from the browser to the terminal ... Not my first rodeo so to speak :-). Next thing would be to load the binaries in debug mode to see the actual line where things go wrong. The error is just too obvious.

Downloaded and installed latest enterprise version, 2.2. The output is below:

crucible:Couchbase iranhutchinson$ couchbase-cli bucket-list -c 127.0.0.1
default
bucketType: membase
authType: sasl
saslPassword:
numReplicas: 1
ramQuota: 268435456
ramUsed: 2249544
crucible:Couchbase iranhutchinson$ couchbase-cli server-info -c 127.0.0.1
ERROR: unable to access the REST API - please check your username (-u) and password (-p)
crucible:Couchbase iranhutchinson$ couchbase-cli server-list -c 127.0.0.1
ns_1@127.0.0.1 127.0.0.1:8091 healthy active
crucible:Couchbase iranhutchinson$

The output of the community version is below:

crucible:Couchbase iranhutchinson$ couchbase-cli server-list -c 127.0.0.1
ERROR: command: server-list: 127.0.0.1:8091, could not access node; please check your username (-u) and password (-p)
crucible:Couchbase iranhutchinson$ couchbase-cli server-info -c 127.0.0.1
ERROR: unable to access the REST API - please check your username (-u) and password (-p)
crucible:Couchbase iranhutchinson$ couchbase-cli bucket-list -c 127.0.0.1
default
bucketType: membase
authType: sasl
saslPassword:
numReplicas: 1
ramQuota: 268435456
ramUsed: 2245160
forecast
bucketType: membase
authType: sasl
saslPassword:
numReplicas: 1
ramQuota: 4026531840
ramUsed: 2232336
crucible:Couchbase iranhutchinson$

As you can see, one cli works sometimes and others not. I've tried it several times and there seems to be issues with the REST service. I even entered the U/P and still the same error. I've seen various reasons around this throughout the forums and posts. It's not consistent it seems. Really need to fix it though. Thoughts? Else, I'll get to binary/sourch debugging to see what goes wrong.