Dependency libcrypto.so.6 fail

Hi all,

My search for the same issue in the forum didn't returned any results. In case I missed it please point me to the right link.
I tried installing 2.0 community edition rpm on the same fedora 14 VM where currently I have 1.1 installed and running but it is failing with following error --
error: Failed dependencies:
libcrypto.so.6 is needed by couchbase-server-2.0.0r-1.i386
libssl.so.6 is needed by couchbase-server-2.0.0r-1.i386
I have checked that I have *.so.10 and I remember I had to create a soft link (*.so.6) to both for 1.1 to install. I was wondering what else might be needed.

TIA

Bikram

1 Answer

« Back to question.

Hi, not sure about fedora 14, but on some other recent RH variants, I've had success with the openssl098e package. For example...
yum install openssl098e
Pls let us know if that worked for you.
Cheers,
Steve

hi Steve,
thx works fine with CentOS 6.0 (and SL 6.0 / RHEL 6.0)
BW
Alex

This same fix works in CentOS 6.2

Same fix worked in default AWS RHEL6 64bit:

[root@***** ~]# sudo rpm --install couchbase-server-community_x86_64_2.0.0-dev-preview-4.rpm
error: Failed dependencies:
libcrypto.so.6()(64bit) is needed by couchbase-server-2.0.0dp4r-722.x86_64
libssl.so.6()(64bit) is needed by couchbase-server-2.0.0dp4r-722.x86_64

[root@***** ~]# uname -a
Linux ip-***** 2.6.32-220.el6.x86_64 #1 SMP Wed Nov 9 08:03:13 EST 2011 x86_64 x86_64 x86_64 GNU/Linux

[root@ip-***** ~]# yum install openssl098e

[root@ip-***** ~]# sudo rpm --install couchbase-server-community_x86_64_2.0.0-dev-preview-4.rpm

Starting couchbase-server[ OK ]

You have successfully installed Couchbase Server.
...

-Rob

I looked into this. There is no openssl098e RPM for fedora. openssl098e are only for RHEL & derivates. I haven't yet discovered a workaround to get couchbase working on Fedora.

Hi All,

I have got error like below when I tried to upgrade to Couchbase 2.0.0 version.
libcrypto.so.6 is needed by couchbase-server-2.0.0-1976.i386
libssl.so.6 is needed by couchbase-server-2.0.0-1976.i386

I have tried yum install openssl098e but got the below error
Loaded plugins: fastestmirror, security
Determining fastest mirrors
Could not retrieve http://mirrorlist.centos.org/?release=6&arch=i386&repo=os error was
14: PYCURL ERROR 7 - "Failed to connect to 2a01:c0:2:4:216:3eff:fe0d:266d: Network is unreachable"
Error: Cannot find a valid baseurl for repo: base

I am executing on 32-bit system with CentOS release 6.3, please let me know what has to be done.

To solve this issue in 32 bit centos 6.3 system first install "openssl098e-0.9.8e-17.el6.centos.2.i686.rpm" and then install "couchbase-server-enterprise_x86_2.0.0.rpm". It had worked for me.

I successfully installed in Fedora 18.
Install openssl098e rpm from below link, which provides libcrypto.so.6 and libssl.so.6

http://rpm.pbone.net/index.php3/stat/4/idpl/15991730/dir/scientific_linu...