Couchbase gem v=1.3.5 fail

My environment:

Windows 7 64bits
Ruby 1.9.3
Rails 3.2

Steps:
Create new app:

rails new couchbase_example -O

Add to Gemfile:

gem 'couchbase'
gem 'couchbase-model'

run:

bundle install

The gem are installed correctly:

couchbase (1.3.5 x86-mingw32)
couchbase-model (0.5.3)

Now, I want generate couchbase.yml:

Rails generate couchbase:config

But something went wrong... if I run server (rails s) the same error too:

C:/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/couchbase-1.3.5-x86-mingw32/lib/couchbase_ext.rb:1:in `require': 126: can not find the specified module

C:/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/couchbase-1.3.5-x86-mingw32/lib/couchbase/1.9/couchbase_ext.so (LoadError)

from C:/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/couchbase-1.3.5-x86- mingw32/lib/couchbase_ext.rb:1:in `'
from C:/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/couchbase-1.3.5-x86-mingw32/lib/couchbase.rb:22:in `require'
from C:/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/couchbase-1.3.5-x86-mingw32/lib/couchbase.rb:22:in `'
from C:/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/bundler-1.3.5/lib/bundler/runtime.rb:72:in `require'
from C:/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/bundler-1.3.5/lib/bundler/runtime.rb:72:in `block (2 levels) in require'
from C:/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/bundler-1.3.5/lib/bundler/runtime.rb:70:in `each'
from C:/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/bundler-1.3.5/lib/bundler/runtime.rb:70:in `block in require'
from C:/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/bundler-1.3.5/lib/bundler/runtime.rb:59:in `each'
from C:/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/bundler-1.3.5/lib/bundler/runtime.rb:59:in `require'
from C:/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/bundler-1.3.5/lib/bundler.rb:132:in `require'
from C:/Users/David/Desktop/ejemplocb/config/application.rb:12:in `'
from C:/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/railties-4.0.2/lib/rails/commands.rb:43:in `require'
from C:/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/railties-4.0.2/lib/rails/commands.rb:43:in `'
from bin/rails:4:in `require'
from bin/rails:4:in `'

I have been trying on differents machines but always the same error..

2 Answers

« Back to question.

There is the similar thread with solution

http://www.couchbase.com/communities/q-and-a/unable-install-couchbase-ge...

I have released new version 1.3.6 with the fix

« Back to question.

Thank you!

But now... when I run the server...

.../gems/couchbase-1.3.6-x86-mingw32/lib/couchbase.rb:63:in `initialize':
failed to create libcouchbase instance (error=0x26) (Couchbase::Error::InvalidUsername)

When I tried the couchbase -v 1.3.2 all works fine...