Couchbase Questions: Couchbase Server

Have a Question? Get it answered by our community

Nithin's picture
Asked 1 month 1 day ago

Failed to reach erlang port mapper (weired issue)

I am trying to add a new server to an existing cluster. I am using community version 2.1.1 on both ubuntu servers on windows azure. I tried to add new server via web interface and via command line. But i am getting following error.

"Failed to reach erlang port mapper....
chuangqi's picture
Asked 1 month 1 day ago

Why there are lots of reading operations to disk when load data using YCSB

I'm a fresh man to Couchbase. I have a question. When I tested the Couchbase using YCSB, I found a phenomenon. At the loading step, there was no reading operations of the disk at the beginning, however, there were lots of reading operations as the loading went on. Why there were so many reading...

cfdltech's picture
Asked 1 month 1 day ago

Why are there 32bit builds when the minimum requirements are 4GB of memory?

The requirements are a little broad. Obviously, the recommended is 16GB of memory but the minimum can be 4GB and the site says that even for testing 1GB could work.

Then, on the download page I see that most OS builds have a 32bit build.

Would that be just for these "test"...

sanket.gupta's picture
Asked 1 month 3 days ago
Latest activity 1 month 2 days ago

AutoScaling on AWS

Hi
I am looking to deploy couchbase as a memcache replacement on AWS.
We are expecting sudden spikes in traffic and hence would like to deploy these machines using an AWS autoScale group.

This comes with a few problems

1. Since machines can go up and down,what IP...

oliverzy's picture
Asked 1 month 4 days ago

Constant CPU Usage on a fresh install on Mac OS X 10.9

Hi,

Today I try to run Counchbase Server 2.2 on my Mac Book Air with Mac OS X 10.9.
I import two sample buckets (beers and gamesim).

And for a long time I don't have any interactions with the server (meaning get/set any documents). The server constantly cost around 10% CPU....

yunjiha's picture
Asked 1 month 4 days ago

sqoop export error help!

hi!
sqoop error help!!!!

[root@Couchbase01 bin]# sqoop export -connect http://localhost:8091/pools --table data --export-dir data
Warning: /usr/lib/hbase does not exist! HBase imports will fail.
Please set $HBASE_HOME to the root...

Nieldy's picture
Asked 1 month 4 days ago
Latest activity 1 month 3 days ago

Can't Read or Write from/to default bucket since Couchbase Server update

A little while back I updated our two Couchbase servers installed on CentOS machines from 2.0 to 2.2.0 Enterprise Edition (build-821-rel), and now I've just realised that any attempt to read or write from/to the "default" bucket fails (tried this from both the Enyim.Caching v2.8.0.0 .NET client...

arik@peerkamp.com's picture
Asked 1 month 4 days ago
Latest activity 3 weeks 5 days ago

Rebalancing issue

I have a 2 node cluster setup on Azure

For testing purposes - both nodes are small vms (1.7 RAM, single core)

I constantly get errors on rebalancing

Rebalance exited with reason {unexpected_exit,
{'EXIT',<0.21261.1>,
{badmatch,
[{'EXIT',
{{...

adurieux's picture
Asked 1 month 5 days ago
Latest activity 1 month 4 days ago

delete() in reduce function ?

Hi all,

I am trying to use a map/reduce combination to be able to perform a partial bulk delete on a bucket.

Here is a sample of a document, :

...
jbee's picture
Asked 1 month 1 week ago
Latest activity 1 month 23 hours ago

Migration from relational

Hi
I hope someone can help since I'm getting lost.
A bit of background might help:
We're building a new release of our software and are looking into NoSQL, given our background with SQL Server for years.
We use a Master-Model approach where our Model is our standard...

Pages