Can't query buckets ... segment fault 11

I had been using Couchbase 2.0.1 on my home and laptop computers (both OSX 10.8.5) with no problem for many months and then suddenly my laptop stopped working. Specifically the ability to use PHP to get or set documents in buckets started returning a "segment fault 11".

In the hope that maybe the latest and greatest Couchbase version would solve this I tried both 2.1 and 2.2 builds of Couchbase Server with exactly the same results. Furthermore, I also went so far as to do a complete clean install of Couchbase. I then manually added in the appropriate buckets and then ran a cbrestore to pull the data in. This operation all worked fine, the admin panel shows all the data there, going into the document is fine, everything looks good. This makes me believe there is something wrong with the PHP client library but I'm not really sure what to think.

I'm using the latest version of the PHP client library (1.2.1) but I had the same problems with the prior stable build (1.1.5) which is what I'm still using on my home computer with zero problems.

I'm desperate to get some help on this as this has me completely stuck. Any help would be greatly appreciated!

1 Answer

« Back to question.

Oh also, for what it's worth I have the latest C libraries too (v2.1.1). This is consistent across both laptop (doesn't work) and home computer (works).

Finally, I forgot to mention that the PHP library DOES allow me to successfully run view queries and get the results back. It's only when trying to work with get/set/etc. for the bucket documents that things fail with the "segment fault 11".